バッファローの無線LANで二重ルーターを解消するには?

パソコントラブル

こんにちは、jazz335です。

昨日までアクセスできていたバッファローのNASに、今日になって急に接続できなくなりました。

インターネットには接続できるので、NASの故障か?と思っていたのですが、原因は二重ルーターでした。

そこで、バッファローのサポートに問い合わせた経緯をご報告します。

自宅のネットワーク環境について

まず、現在の利用環境を説明します。
パソコンOS:Windows10(DELL Inspiron15ノート型)
NAS:Link Station LS210DC(バッファロー)
無線LANルーター:WSR-2533DHP(バッファロー)
ONU:PR-400KI(NTT東日本)

NASにアクセスできない時の問題の切り分け手順

バッファローのNAS担当サポートに電話で問い合わせして、次の手順で問題の切り分けを行いました。

1.NASの電源OFF/ON

これについては、サポートに問い合わせる前に自分で試していたのですが問題は解消されませんでした。

2.パソコンのWi-FiをOFFにしてLANケーブルでパソコンとNASを接続する

パソコンのWi-FiをOFFにすることで、無線LANに問題がないか確認します。

サポート担当者の指示に従って、パソコンのタスクバーにあるWi-FiアイコンからOFFの設定に切り替え、LANケーブルでノートPCとNASを直結します。

すると、正常にNASのフォルダを開くことができました。

ただ、Link StationのソフトであるNAS Navigater2の画面にNASのアイコンが表示されない状態です。

とすると、NAS本体の故障というよりもネットワーク機器に問題がある可能性があります。

3.コマンドプロンプト画面でインターネット接続の経路を確認する

タスクバーの検索窓にCMDと入力してコマンドプロンプトの画面を立ち上げて、カーソルが点滅していることろにtracert yahoo.co.jpと入力し、yahoo.co.jpへのルートを確認します。

画像が小さくて見えづらいと思いますので、下記に結果を表示します。
———————————————————
C:\Users\User>tracert yahoo.co.jp
yahoo.co.jp [183.79.135.206] へのルートをトレースしています
経由するホップ数は最大 30 です:

1     1 ms    <1 ms     1 ms  buffalo.setup [192.168.11.1] 2     2 ms     1 ms     1 ms  ntt.setup [192.168.1.1] 3     *        *        *     要求がタイムアウトしました。
4     *        *        *     要求がタイムアウトしました。
5     *        *        *     要求がタイムアウトしました。
———————————————————–

この画面で、パソコンからYahoo!のホームページまでどういう経路をたどっているかがわかります。

そして、問題になっているのが1行目(バッファロー無線LANルータ)と2行目(NTT東日本ONU)のIPアドレスの3番目(第3オクテット)が違うということです。

buffalo.setup [192.168.11.1]

ntt.setup [192.168.1.1]

つまり、同じネットワーク内にルーターが2つ存在する状態になっていることによって、NASをうまく認識できていないことが考えられます。

では、なぜこの設定で今まで使えていたのか?という素朴な疑問が湧きます。

そこでサポート担当者に聞いてみると、IPアドレスが自動取得設定になっている場合、二重ルーターでも問題なくNASが使える場合があるとのこと。

ただ、なんらかのきっかけで割り当てられるIPアドレスが変わった結果、ネットワーク内で機器が認識できない現象が発生するようです。

また、この場合でもインターネット(外部サイト)には接続することができるため、問題の切り分けにある程度のネットワーク知識が必要になります。

スポンサードリンク



二重ルーターを解消する方法

さて、以上の問題切り分けにより、NASにアクセスできない原因をつきとめることができました。

ただ、会話をしているのがNASのサポート担当者なので、ここから先は無線LANルータのサポート担当者と話してほしいとのこと。

そこで、電話を別の担当者に転送してもらい、下記の状況を伝えました。

  • NTTのONUとバッファローの無線LANルーターで二重ルータが発生している。
  • tracertで上記の現象を確認済
  • バッファローのルーター機能を切って、中継器的な役割で使いたい

これを伝えると、無線LANルーターのサポート担当者は下記の手順を教えてくれました。

1.無線LANルーターの電源をOFF

2.背面のスイッチを、ROUTERからAPに切替し、さらにAUTOからMNUALに切替する。

3.無線LANルータの電源をON

これを実行した後、パソコンからエクスプローラでNASのフォルダにアクセスすると、無事に開くことができました。

サポート担当者の話によると、無線LANルーターの設定はネットワークの知識がない人でも扱いやすいように、AUTOの設定を推奨しているようです。

ただ、これにより今回のような現象が発生することがあるとのことでした。

いやぁ、勉強になりました。バッファローのサポート担当者の方にはこの場を借りて御礼申し上げます。

 

スポンサードリンク